Wednesday, October 19, 2011

Upgrade to JoyBidder Pro 1.7.7 for Firefox 7.x Now

It appears some users have trouble auto-updating to the latest version of JoyBidder eBay Auction Sniper Pro for Firefox. From what I have heard so far, it happens that if you upgrade Firefox to 7.x without JoyBidder being updated to the compatible version (1.7.7) first, Firefox will disable JoyBidder.

If you have this problem, please manually install the latest version of JoyBidder Pro for Firefox at